Skip to content

asm.js

Emscripten – Ubuntu 14.04

Recently got started with asm.js and wanted to do something simple. The first step to getting started is installing Emscripten or similar. When I installed it on Ubuntu 14.04 following the guide I received this error:

CRITICAL:root:The JavaScript shell used for compiling ([‘node’]) does not seem to work, check the paths in ~/.emscripten

The reason for this was because the file ./emscripten does not exist. To fix this change line 209 in ~./tools/shared.py from:

  • if not EM_CONFIG:
    EM_CONFIG = ‘~/.emscripten’

to

  • if not EM_CONFIG:
    EM_CONFIG = ‘~/.emscripten.py’
Twitter Auto Publish Powered By : XYZScripts.com